Introduction to the ds9 Interface

Return to the DS9 Users Manual


Synopsis

This thread provides an overview of the key components of the ds9 graphical user interface (GUI).

If you encounter any problems, please email saord @ cfa.harvard.edu.


Contents


The ds9 Interface

This thread uses Chandra data from an observation of the Trapezium Cluster (ObsID 1522). The default ds9 GUI is shown in Figure 1. The main components are numbered:

  1. Menu bar
  2. Information panel
  3. Panner
  4. Magnifier
  5. Buttons
  6. Display frame
  7. Colorbar

The default setup is a "horizontal layout", with the information panel, panner, magnifier, and buttons displayed horizontally across the window. This may be changed to "vertical layout" in the View menu (Figure 2).

Note that the colorbar remained horizontal at the bottom of the display frame. This may be changed with the "vertical colorbar" option in the "View" menu.

1. Menu bar

The menu bar provides access to all of ds9's capabilities. For a complete description of each menu, refer to the Menu bar section of the Reference Manual.

All ds9 menus can be "torn off" to be a separate window from the main GUI. To tear off a menu, select the dashed line, which is the first item of each menu (shown in Figure 4). The menu will become its own window.


2. Information panel

The information panel displays information about the data file and the values at the cursor position. In Figure 5, the object name has been loaded from the header of the data file. The image value and position (in WCS, physical, and image coordinates) are updated in real time as the cursor is moved.

The fields of the information panel can be customized from the "View" menu. Any of the default entries can be removed, and additional fields can be added (e.g. detector coordinates, min/max data values).


3. Panner

The panner allows the user to view areas of the frame which are outside of the current field of view. Although the display frame is filled by the data, the panner indicates that more of the image is available. Clicking and dragging the viewing bounding box in the panner - shown in blue in Figure 6 - will display a different portion of the image.

The panner also contains axes to indicate the directions of North and East and the directions of the physical (x,y) data axes.


4. Magnifier

The magnifier displays a magnified view of the current cursor location. The magnifier cursor - the small square in the center of Figure 7 - outlines the size and orientation of one pixel, taking into account the current frame zoom and orientation.


5. Buttons

The button bar duplicates many of the options available from the menu bar. The buttons provide quick access to change the most frequently-used ds9 actions (e.g. changing the scale and color bar, blinking and tiling frames).

When a category is chosen from the top row, the options within that category are displayed in the bottom row of buttons. In Figure 8, the color category is chosen and the bottom row shows the ten most-used colormap options (additional colormaps are available from the "Color" menu).


6. Display frame

The display frame is the area of ds9 where the FITS image is shown. In Figure 1, a single frame is shown.

Multiple frames can be opened in ds9 at the same time. In Figure 9, nine frames have been opened and set to "tile" display from the "frame" button. The current frame is indicated by a blue outline around it (second row, center frame). How the frames are tiled is set in the "Frame → Frame Parameters → Tile" menu; the default is to tile the frames in a grid.

If the display is set back to "single", then the current frame fills the display area. The other frames can be accessed via the "previous" and "next" options in the buttons bar (or from the "Frame" menu).

The "blink" option may also be used with multiple frames. When blink is turned on, ds9 cycles through all the available frames. The blink interval is set in the "Frame → Frame Parameters → Blink Interval" menu.


7. Colorbar

The colorbar displays the colormap, bias, and contrast settings. The colormap correlates the colors used in the image with the pixel values in the data.

To change the colormap, use the "Color" menu or button. The contrast and bias can be adjusted by right-clicking and dragging on the ds9 display. The "Color → Colormap Parameters" dialog box can also be used to change contrast and bias.


Setting and Saving View Preferences

All of the view options described in this thread can be set and saved as a preference. Open the "Preferences" dialog box from the "Edit" menu and select the "View" tab, shown in Figure 11.

The "Default" menus are used to set the defaults of the "View" menu and buttons. For instance, uncheck the "Panner" item under "Menu" and the panner won't be displayed when ds9 is launched. (Note that some options require ds9 to be restarted before they take effect.)

After setting the desired preferences, select "Save". User preferences are stored in .ds9.prf. At startup, ds9 looks for the preferences file in the following directory order: ./, $HOME, /usr/local/lib, /opt/local/lib.


History

06 Jul 2009 Original version

Return to the DS9 Users Manual